aboutsummaryrefslogtreecommitdiffhomepage
path: root/derivation.nix
diff options
context:
space:
mode:
Diffstat (limited to 'derivation.nix')
-rw-r--r--derivation.nix3
1 files changed, 1 insertions, 2 deletions
diff --git a/derivation.nix b/derivation.nix
index d179c8f..09bbfd0 100644
--- a/derivation.nix
+++ b/derivation.nix
@@ -48,7 +48,6 @@ with (
buildPhase = ''
runHook preBuild
HOME="$PWD"
- DFLAGS="-O2 -inline"
for DC_ in dmd ldmd2 gdmd; do
echo "- check for D compiler $DC_"
DC=$(type -P $DC_ || echo "")
@@ -60,7 +59,7 @@ with (
exit "Error: could not find D compiler"
fi
echo "$DC_ used as D compiler to build $pname"
- dub build --compiler=$DC --build=release --combined --skip-registry=all
+ dub run --compiler=$DC --build=release --combined --skip-registry=all
runHook postBuild
'';
checkPhase = ''